Updating My SDDC on Ravello to vSphere and vSAN 6.7

So after the availability of NSX 6.4.1, with support for vSphere 6.7, it was time to update my Ravello lab to the latest versions. Last Friday I updated NSX, through the use of the Upgrade Manager (blog can be found here: Update of NSX).

In the late afternoon, early evening, I thought let’s update the rest to version 6.7.

The update of vCenter was pretty straightforward, as might be expected, because VMware has taken a lot of effort in making this a very workable solution.

When I tried updating the hosts to ESXi 6.7, through Update Manager, however, I got an error message saying that the hardware was unsupported:

Unsupported CPU

So I decided to restart from scatch and create a completely new cluster, based on new VM’s.

When creating the VM’s, I used the same base VM I used earlier to install ESXi. When I started the VM, connected to the ISO file, which contained ESXi 6.7, I didn’t get any screen shown. I tried the same VM, but this time with the ESXi 6.5 ISO and than I got an installation screen (but not for the right version ;)). So I thought there must be someone out there, who came accross the same issue and yes, there was. In this blog is explained how to configure the Ravello VM’s, in order to run ESXi 6.7: https://www.snurf.co.uk/oracle/ravello/quick-and-dirty-settings-to-make-esxi-6-7-work-on-oracle-ravello/

After reading this blog I first decided to change the configuration of my current hosts to match the config as described in the blog, and lo and behold… That worked. So changed the configuration of all hosts to SandyBridge and remediated them, leading to a 6.7 cluster:

Upgraded-hosts

Last step is to update the vSAN File Format from 5 to 6 (basically a one-click upgrade, especially since I allowed for reduced availability) and the cluster is completely upgraded for all SDDC components.

That was very easy and I must say I like the HTML5 interface very much. There are still some things missing (like the Update Manager options, you get in the Flex client).

Haven’t used the HTML5 client frequently until now, because of the Networking & Security tab, but since more and more is becoming available in HTML5, I’ll soon use this as my new default.

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s